Networking Issues DC2 and DC3

Incident Report for Liquid Web - Services

Monitoring

Our Liquid Web Networking team identified the the networking issue with our DC2 & DC3 data centers. Networking is currently back online.

We will continue to monitor the system to ensure stability.

Thank you for your continued patience.
Posted Nov 05, 2025 - 13:57 EST

Update

We are continuing to investigate this issue.
Posted Nov 05, 2025 - 12:03 EST

Investigating

Liquid Web Systems Engineers are currently investigating a networking issues in our DC2 & DC3 Data Center.

Liquid Web's Networking team have been engaged and are working to restore service as quickly as possible. We will provide further updates as soon as they become available.

Our support team is on standby if you need any help or have questions or concerns. If you have any questions or concerns, please contact a member of our support team via live-chat or ticket (support@liquidweb.com).
Posted Nov 05, 2025 - 12:02 EST
This incident affects: Network (LAN Network).