My.liquidweb.com and Manage.liquidweb.com Redirected to Maintenance Pages, and Support Delays
Incident Report for Liquid Web - Services
Resolved
Following extended monitoring with no further performance issues, this issue is considered resolved.
Posted Jan 21, 2023 - 08:41 EST
Monitoring
A fix has been put into place and our sites are no longer being redirected, and Support delays are resolved. We are currently monitoring to ensure no further issues.
Posted Jan 20, 2023 - 17:28 EST
Investigating
Our teams are currently investigating an issue that is causing provisioning errors for new services. The same issue is also causing delays in providing support. While these issues are addressed we have redirected my.liquidweb.com and manage.liquidweb.com to maintenance pages. We will update this status post as more information becomes available.

If you have any questions or concerns, please contact a member of our support team via live-chat, ticket (support@liquidweb.com), or by phone at 1-800-580-4985, 1-517-322-0434 (international).
Posted Jan 20, 2023 - 15:35 EST