Potential Increase in Support Response Times
Incident Report for Liquid Web - Services
Resolved
We have identified an issue and implemented the fix. Issue has now been resolved.
Posted Jun 11, 2022 - 04:42 CDT
Investigating
We are currently investigating errors within our chat and ticketing system due to recent maintenance. At the moment, chat and ticketing systems are fully operational, however, there is a possibility of increased response time from LW Support. Customers can contact Liquid Web via phone during this time, which at the moment is not affected.

Should you have any questions or concerns, feel free to reach out to us via phone at 1-800-580-4985 (1-517-322-0434).
Posted Jun 11, 2022 - 03:53 CDT
This incident affected: Support Services (Chat Support, Ticket Support).