Premium Business Email Control Panel Access

Incident Report for Liquid Web - Services

Resolved

This incident has been resolved.
Posted Oct 03, 2025 - 16:21 EDT

Monitoring

A fix has been implemented by our email vendor, and control panels are now accessible, and we are actively monitoring to ensure everything continues to function normally.

Thank you for your patience.
Posted Oct 03, 2025 - 09:27 EDT

Investigating

We are aware of an issue with our email vendor’s Control Panel. Our email vendor has acknowledged the problem and is working toward a resolution.

Please note that this may cause some delays in providing support for Premium business email. However, this issue does not impact email delivery or any email services.

If you have any questions, don't hesitate to contact a member of our support team via live chat or Case.
Posted Oct 02, 2025 - 08:44 EDT
This incident affected: Business Email.