Credit Card Processing Failures
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Jul 28, 2021 - 18:31 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2021 - 15:27 CDT
Investigating
We are currently investigating an issue where orders placed with a credit card are timing out. We will update this status post as more information becomes available.

If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Jul 28, 2021 - 14:44 CDT