Authentication-Check Policy Bounceback Emails
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved. Please be sure to follow best practices and ensure all sending domains for email have proper SPF or DKIM records.

If you have any questions, contact a member of our support team via live chat, ticket, or by phone at (800)-580-4985 or (517)-322-0434 (international).
Posted Feb 03, 2023 - 15:30 EST
Monitoring
The additional layer of validation SPF and DKIM is critical to reducing spam. Incorrect records will need to be updated to ensure proper mail delivery to most major providers. If needed, please reach out to our support team for assistance updating DNS.
Posted Jan 31, 2023 - 22:23 EST
Identified
We have been made aware by our Postmaster that Hosted Email users are experiencing bounce back emails from major mail providers due to a recent change in their Security-Check Policies. To resolve these bounces, the sender should update their Domain's DNS records to include the proper SPF and DKIM record.
Please ensure both of the mentioned records are added to your domain's DNS.
Here are the documents with steps and information on the SPF and DKIM records:

https://help.liquidweb.com/s/article/Managing-DNS-for-Premium-Business-Email

https://help.liquidweb.com/s/article/Enabling-DMARC

If you have any questions, contact a member of our support team via live chat, ticket, or by phone at (800)-580-4985 or (517)-322-0434 (international).
Posted Jan 30, 2023 - 17:37 EST
This incident affected: Business Email.