Business Email Incoming Delivery
Incident Report for Liquid Web - Services
Resolved
The issue with incoming delivery has been resolved.
Posted Nov 29, 2022 - 15:15 CST
Monitoring
At this time our email vendor has identified the root cause and has provided a resolution. Users should be able to receive incoming emails without any issue.

We will continue to monitor this situation for any further issues.
Posted Nov 29, 2022 - 14:39 CST
Identified
Our email vendor is investigating reports from users having issues with incoming delivery. Not all users appear to be impacted at this time.

Engineers are actively working towards a resolution. We will provide more updates as they become available.
Posted Nov 29, 2022 - 11:33 CST
This incident affected: Business Email.