Hosted Exchange Connectivity Issues
Incident Report for Liquid Web - Services
Resolved
Rackspace has completed the email data recovery, providing PSTs for download through the Hosted Exchange portal on an individual mailbox basis. The data will be available for download through March 31, 2023. Don't hesitate to contact our support team if you encounter any issues downloading the data.

As a reminder, Rackspace will not resume Hosted Exchange services from their data centers. A permanent long-term solution for replacing the Hosted Exchange mailboxes is required. If needed, our team is available to discuss options for email hosting to help you make a well-informed decision regarding email hosting.

We sincerely apologize for the disruption this incident caused and will send all additional communications around this issue via our ticketing system.
Posted Mar 01, 2023 - 12:13 EST
Update
Thank you for being so patient as we continue to work with Rackspace to get the remaining PST files following the Hosted Exchange outage.

Please remember that:

-- Rackspace is moving all direct clients requiring Hosted Exchange to Microsoft Exchange Online. The impacted Exchange servers in the Rackspace data centers will not be brought back online.

-- All customers affected must choose a permanent long-term solution for their Hosted Exchange mailboxes. We would be happy to discuss those options to help you make the best choice for each unique need. Please contact us if you still need to make long-term plans so we can assist you.

-- Rackspace stated those PST files would only be available for a limited time, approximately 30 days. All customers must download their data as it becomes available.

-- You can log in to your email control panel at any time to see what mailboxes may have new PST files available for download. As PST files become available for download, you can use the following instructions to download them and import them into Outlook: https://www.nexcess.net/help/hosted-exchange-mailbox-download/

If you have questions about that or wish to discuss options, please do not hesitate to contact a member of our support team via ticket, email to support@liquidweb.com, or by phone at 1-800-580-4985, 1-517-322-0434 (international) for further assistance.
Posted Jan 30, 2023 - 10:21 EST
Update
We continue to appreciate your patience for the ongoing outage with the Hosted Exchange Platform which we provide in partnership with Rackspace. You still may see delays in message delivery due to high volume and activity.

Our vendor is working around the clock to secure and make available email for download as they are able to restore mailbox data. This has been a slow process. More information on that process is on their status page here:
https://status.apps.rackspace.com/index/viewincidents?group=2&start=1671426000

As we get updated information on Exchange mailboxes that have email available for download we will communicate that with our customers through a ticket. As customer PST files become available for download you can use the following instructions to download them and import them into Outlook:
https://www.nexcess.net/help/hosted-exchange-mailbox-download/

For anyone who still may need a standard mailbox (user1@) as a work around please review the following help center article, which will show you how to connect to a working mailbox:
https://help.liquidweb.com/s/article/Hosted-Exchange-Extended-Outage

Please know that the Hosted Exchange environment at Rackspace will not be coming back online as a service. It is important all Hosted Exchange customers determine a long term email solution for their business needs.

If you have questions about that or wish to discuss options please do not hesitate to contact a member of our support team via ticket, email to support@liquidweb.com, or by phone at 1-800-580-4985, 1-517-322-0434 (international) for further assistance.
Posted Jan 04, 2023 - 13:28 EST
Update
We continue to appreciate your patience for the ongoing outage with the Hosted Exchange Platform which we provide in partnership with Rackspace.

For anyone who still may need a standard mailbox (user1@) as a work around please review the following help center article, which will show you how to connect to a working mailbox:
https://help.liquidweb.com/s/article/Hosted-Exchange-Extended-Outage

Additionally, you may see delays in message delivery due to high volume and activity. We have also made our vendor aware of this and they are looking to improve delivery times as soon as possible.

We are asking all customers to begin thinking about a long term solution for their email. We will be contacting you in phone calls and/or tickets to present those options.

Our vendor has updated information on the Hosted Exchange recovery process here: https://status.apps.rackspace.com/index/viewincidents?group=2&start=1671426000

Thank you again for your patience throughout this event, and if you have any trouble accessing the temporary solution, please do not hesitate to contact a member of our support team via ticket, email to support@liquidweb.com, or by phone at 1-800-580-4985, 1-517-322-0434 (international) for further assistance.
Posted Dec 19, 2022 - 12:34 EST
Update
We sincerely apologize for the interruption in service you have experienced on the Premium Business Email, Hosted Exchange Platform which we provide in partnership with Rackspace. Our Engineering teams have been working non-stop and in conjunction with Engineers at Rackspace since this incident began early Friday. We have now implemented a temporary solution that will allow affected customers the ability to send and receive email messages for the affected mailbox(es).

Please review the following help center article, which will show you how to connect to a working mailbox:
https://help.liquidweb.com/s/article/Hosted-Exchange-Extended-Outage

A Support ticket with further instructions for access has also been opened on your customer account at https://my.liquidweb.com/

Additionally, you may see delays in message delivery due to high volume and activity. We have also made our vendor aware of this and they are looking to improve delivery times as soon as possible.

Thank you again for your patience throughout this event, and if you have any trouble accessing the temporary solution, please do not hesitate to contact a member of our support team via ticket, email to support@liquidweb.com, or by phone at 1-800-580-4985, 1-517-322-0434 (international) for further assistance.
Posted Dec 05, 2022 - 13:48 EST
Update
Liquid Web is working closely with Rackspace Technology, our vendor for our Premium Business Email solution. This is an outage impacting all Rackspace Hosted Exchange products.

Our teams have been actively engaged with Rackspace Technology throughout this situation and we are working closely to deploy a temporary solution to allow our customers to send and receive emails.

We will notify customers as soon as this temporary solution is available.
Posted Dec 04, 2022 - 15:06 EST
Update
We sincerely thank you for your patience while we work to resolve the hosted email exchange issues

We have been working with our email vendor on possible solutions. After much deliberation we have identified a method that will function as a workaround to be able to send/receive emails until a permanent fix is applied to the hosted exchange environment. We will be reaching out to the individual customers this is affecting with detailed instructions about the process of moving forward.

We will provide further updates as we progress through this process
Posted Dec 03, 2022 - 23:05 EST
Update
We thank you for your patience regarding this issue.

Our email vendor is continuing to investigate the connectivity and login issues to our Exchange environments. Users may experience an error upon attempting to access OWA (Webmail) & sync mail to their email client, or a prompt to re-enter their password.

We will provide further updates as the become available.
Posted Dec 03, 2022 - 08:10 EST
Update
Our email vendor is continuing to investigate the connectivity and login issues to our Exchange environments. Users may experience an error upon attempting to access OWA (Webmail) & sync mail to their email client, or a prompt to re-enter their password.

We will provide further updates as the become available.
Posted Dec 03, 2022 - 03:44 EST
Update
Our email vendor has assured us that all hands are on the deck at this time, and that the right resources have been engaged on this issue. All new updates will be posted here as they become available.
Posted Dec 02, 2022 - 10:19 EST
Update
Our email vendor is continuing to investigate the connectivity and login issues to our Exchange environments. Users may experience an error upon attempting to access OWA (Webmail) & sync mail to their email client, or a prompt to re-enter their password.

We will provide further updates as the become available.
Posted Dec 02, 2022 - 07:13 EST
Update
Our email vendor is continuing to investigate reports of connectivity issues to the Hosted Exchange Email Environment.

We will provide further updates as the become available.
Posted Dec 02, 2022 - 05:58 EST
Monitoring
Our email vendor is investigating reports of connectivity issues to the Hosted Exchange Email Environment. Users may experience an error upon accessing the Outlook Web App (Webmail) and syncing their email client(s).

We will provide further updates as the become available.
Posted Dec 02, 2022 - 04:09 EST
This incident affected: Business Email.