Business Email Delivery Delays
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Dec 16, 2019 - 13:46 EST
Monitoring
Email vendor confirmed that the issue should be resolved. The delayed email is still being worked through but new email should be delivered normally. We will continue to monitor the issue and will update here if we see any further issues.
Posted Dec 16, 2019 - 13:13 EST
Investigating
Our Email Vendor is reporting issues with Email Delivery having some fairly large delays. We are keeping communications open to stay current on this issue and will provide any updates via this ticket.

We appreciate your patience in the matter and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Dec 16, 2019 - 12:55 EST
This incident affected: Business Email.