Premium Business Email Control Panel Issues
Incident Report for Liquid Web - Services
Resolved
This issue has been resolved.
Posted Apr 02, 2024 - 08:47 EDT
Identified
Our email vendor has identified an issue with the email control panel where most functions are not operating as intended. Engineers are actively engaged in resolving the issue.

This may be affecting the ability to manage or write changes to mailboxes.

We appreciate your patience in the matter and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Apr 01, 2024 - 14:50 EDT
This incident affected: Business Email.