Phone Service Degraded
Incident Report for Liquid Web - Services
Resolved
This issue is now resolved. All contact phone numbers are functioning as expected at this time.
Posted Aug 22, 2023 - 14:07 EDT
Identified
Our teams have identified ongoing impacts due to this issue. The number (517)-322-0434 is still functioning as expected and can be used to reach our teams. We will update this status post as more information becomes available.
Posted Aug 22, 2023 - 10:38 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 21, 2023 - 23:57 EDT
Investigating
We are currently investigating an issue reaching our teams via the phone number (800)-580-4985. The number (517)-322-0434 is still functioning as expected. We will update this status post as more information becomes available.

We appreciate your patience in the matter and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (517)-322-0434 (international).
Posted Aug 21, 2023 - 17:21 EDT