Phone Issues
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Feb 17, 2023 - 17:14 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 16, 2023 - 22:37 EST
Identified
We are currently experiencing issues with our Phone system. If you are unable to reach us please feel free to initiate a chat, create a ticket, or call back later and we will be with you as quickly as we can.

Thank you for your patience as we work to resolve this issue. We will update this status with any additional details. We are available to assist with any questions or concerns via livechat or ticket (https://help.liquidweb.com/s/contactsupport)
Posted Feb 16, 2023 - 19:44 EST
This incident affected: Support Services (Phone Support).