GitHub Peformance Impact

Incident Report for Liquid Web - Services

Resolved

This incident has been resolved.
Posted Aug 18, 2026 - 16:17 EDT

Identified

GitHub is reporting degraded performance via their status page this morning:
https://www.githubstatus.com/

Per the page, this problem may be affecting Pull Requests, Issues, Copilot, Actions, Webhooks, and API requests, among other services. Customers should follow the GitHub status page for the latest information.
Posted Aug 17, 2026 - 11:35 EDT