Incoming Phone Call Issues
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Feb 01, 2023 - 13:43 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 01, 2023 - 13:14 EST
Investigating
Our team is investigating an issue with our phone system at this time. They are diligently working on this and we will update this status with more information when we have it.

In the mean time if calls are not working please feel free to contact us via live chat or ticket from your account or at support@liquidweb.com.
Posted Feb 01, 2023 - 11:37 EST
This incident affected: Support Services (Phone Support).