Support and Billing System Maintenance
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Jan 12, 2023 - 04:46 CST
Update
We are continuing to investigate this issue.
Posted Jan 12, 2023 - 04:45 CST
Investigating
Nexcess Systems Engineers will be conducting scheduled maintenance on the underlying systems that provide the Nexcess customer portal (https://my.nexcess.net/) and internal billing systems. Customer services will not be affected by this maintenance. No interruption in service of the systems affected are expected. However, Support via ticket and live chat may be delayed during the window.

You may subscribe to further updates for this maintenance below. We appreciate your patience as our Engineering teams work to maintain our platform. If you have any further questions or concerns, please feel free to reach out to us by email at support@nexcess.net or by calling 866-639-2377, 1-313-279-0722 (international)
Posted Jan 12, 2023 - 04:45 CST