Premium Business Email Webmail Disruption
Incident Report for Liquid Web - Services
Resolved
At this time all systems are back up and functioning as normal.
Posted Oct 21, 2020 - 10:25 CDT
Investigating
We are working with our Vendor to identify the issue causing slowness when logging into Webmail for our Premium Business Email Service. Affected Users will experience delays in downloading attachments. In addition, when trying to log into webmail May experience delays or the following error "webmail site may have been misconfigured, please try again" when logging in.

If you have any questions, please contact a member of our support team via live-chat and ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Oct 20, 2020 - 15:41 CDT
This incident affected: Business Email.