Email Blacklisting
Incident Report for Liquid Web - Services
Resolved
This issue has been resolved. Thank you for your patience as we worked through these issues with our Email vendor.
Posted Jun 04, 2021 - 08:14 EDT
Monitoring
We continue working with our email vendor to resolve an issue some Premium Business Email users have reported with deliverability impacting some external recipients. Our vendor has taken action to resolve the issue but it may take some time for the fix to fully go into effect. Thank you for your continued patience.

As we have additional information we will update this post. If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted May 27, 2021 - 14:37 EDT
This incident affected: Business Email.