Business Email Control Panel Degraded
Incident Report for Liquid Web - Services
Resolved
This issue is now resolved.
Posted Jan 31, 2023 - 16:38 EST
Update
Email Engineers are still working to resolve errors and issues when using the email control panel. We will share updates as we receive them.
Posted Jan 31, 2023 - 12:30 EST
Identified
Our email vendor let us know they are experiencing some issues with the Control Panel where users might see random error messages and some lag while making changes on the Control Panel. Email Engineers are working to rectify the issue at this time.

We will update this status when we have more information.
Posted Jan 31, 2023 - 09:02 EST
This incident affected: Business Email.