Payment Issues
Incident Report for Liquid Web - Services
Resolved
This issue has been resolved. Payments are functioning as expected.
Posted Feb 10, 2021 - 08:33 CST
Investigating
We have become aware of payments failing when using Visa cards. Our teams are currently investigating the issue. Additional information will be provided once it is made available.

If you have any questions, please do not hesitate to contact a member of our support team via live-chat or by toll-free phone at 1.800.580.4985 or international at +1.517.322.0434.
Posted Feb 09, 2021 - 08:41 CST