Premium Business Email Login Issues

Incident Report for Liquid Web - Services

Resolved

The issue with logging into the Premium Business Email via webmail has been resolved. Thank you for being so patient!
Posted Oct 05, 2024 - 10:31 EDT

Identified

We are currently experiencing issues with logging into the Premium Business Email. We are working with our email provider to resolve this as quickly as possible.

Please note that email delivery has not been impacted.

We will update this post with further information as it becomes available.

If you have any questions, please do not hesitate to contact a member of our support team via live chat or ticket.
Posted Oct 04, 2024 - 23:41 EDT
This incident affected: Business Email.