Email Issues
Incident Report for Liquid Web - Services
Resolved
Resolved - The incident is now closed.
Posted 23 days ago. Sep 23, 2019 - 17:23 CDT
Monitoring
A solution has been deployed and access to Hosted Email is returning to normal.
Posted 23 days ago. Sep 23, 2019 - 17:16 CDT
Investigating
We are investigating an issue that is affecting our Hosted Email environment. We are working with our email team to resolve the issue as soon as possible. More details will be posted as they become available. We apologize for the inconvenience.
Posted 23 days ago. Sep 23, 2019 - 17:10 CDT
This incident affected: Business Email.