Issues Accessing Hosted Exchange Environment

Incident Report for Liquid Web - Services

Resolved

At this time the vendor is seeing the Outlook webmail application is now responding as intended and users are able to successfully login.
Posted Sep 13, 2022 - 17:45 EDT

Monitoring

At this time our email vendor has implemented a fix on the backend. They are showing positive results and requesting users who have had difficulty logging into the Outlook Webmail Application to retry.
Posted Sep 13, 2022 - 16:06 EDT

Identified

Our email vendor is aware of an issue affecting a portion of the Hosted Exchange 2013 environment. Some users on this platform cannot access the Outlook Web Application. Mail clients are not impacted at this time. We recommend users to clear cache, cookies, restart browser and retry. They are investigating this further and will provide updates as they become available.
Posted Sep 13, 2022 - 12:33 EDT
This incident affected: Business Email.