Scheduled Network Maintenance, DC3

Scheduled for May 8, 06:00 - 10:00 EDT

Update

This maintenance was originally scheduled for May 1st at 6am EDT. We have rescheduled the maintenance. It will now begin May 8th at 6am EDT.
Posted Apr 30, 2025 - 10:43 EDT

Scheduled

Liquid Web Network Engineers will perform scheduled maintenance on network infrastructure supporting a subset of customer services in our DC3 Data Center in Lansing, Michigan. There is no expected service interruption, however, during this maintenance some customers may experience brief latency.

Our support team is on standby if you need any help or have questions or concerns. You can connect with us through the following channels:

Live Chat: https://my.liquidweb.com/
Email: support@liquidweb.com

We appreciate your understanding and patience as we work to provide you with a better service.
Thank you for your continued support.

System Maintenance Reference: [CC-12409]
Posted Apr 29, 2025 - 17:47 EDT
This scheduled maintenance affects: Network (LAN Network) and Data Centers (DC3 - LAN).