Premium Business Email Webmail Issues
Incident Report for Liquid Web - Services
Resolved
Our Email vendor has reported the issues affecting webmail login are now resolved. We have confirmed that we are able successfully access mailboxes using the webmail link: https://webmail.liquidweb.services/. If you have any additional questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Sep 09, 2024 - 12:15 EDT
Investigating
Our email vendor is Investigating an issue with the Premium business webmail access. Engineers are actively engaged in resolving the issue.

This may be affecting the ability to manage the emails.

We appreciate your patience in the matter, and if you have any questions, please get in touch with a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Sep 09, 2024 - 10:08 EDT
This incident affected: Business Email.