Premium Business Email connectivity issues
Incident Report for Liquid Web - Services
Resolved
Our email vendor has let us know the issue is now resolved and Webmail is operating as normal.
Posted Oct 18, 2021 - 13:12 CDT
Monitoring
A solution has been put in place and users are beginning to successfully connect to Webmail. Additional updates will be posted as they are available.
Posted Oct 18, 2021 - 11:47 CDT
Update
We are aware of an issue that is affecting our Webmail environment. Users attempting to access their mailbox via our Webmail interface will experience an error or the page may not load. Some users may experience the following error:

"Too Many Requests. We've had too many requests. Please wait a minute and try again."

We recommend users access their email via a mail client such as Outlook as a workaround.

Email delivery is not impacted at this time.
Posted Oct 18, 2021 - 08:49 CDT
Investigating
Our email vendor is investigating reports of connectivity issues to the Webmail platform. Users may experience an error upon attempting to login. We will provide further updates as they become available.
Posted Oct 18, 2021 - 08:28 CDT
This incident affected: Business Email.