The problem with blacklisting Premium Business Email (PBE) vendor IP addresses has not been fully resolved yet. As a workaround, customers are advised to try resending their emails after some time. The system may utilize random IP addresses, which could result in successful email delivery.
We are maintaining close communication with the vendor and are committed to facilitating a quicker resolution.
We appreciate your patience and will provide updates as soon as more information becomes available.
If you have any questions or concerns, please get in touch with a member of our support team via live chat or by ticket (support@liquidweb.com).
Posted Apr 29, 2025 - 08:35 EDT
Update
Our Premium Business Email (PBE) vendor continues working with various email providers and RBLs to delist the impacted IP addresses currently causing email delivery issues.
We remain close to the vendor and are actively following up to support a faster resolution.
We appreciate your patience and will provide further updates as soon as new information becomes available.
If you have any questions or concerns, please get in touch with a member of our support team via live chat or by ticket (support@liquidweb.com).
Posted Apr 23, 2025 - 09:23 EDT
Identified
Our Premium Business Email (PBE) vendor is currently facing issues where some of the IP addresses have been blocked by Spamcop ATT, Hotmail, MSN and Microsoft. We are in talks with our vendor and they are actively addressing the situation and working towards a resolution.
As a workaround, customers may try again after some time. The system may use random IP addresses, so it is not guaranteed that the same IP will be used to send emails again.
Further updates will be provided as soon as more information becomes available.
If you have any questions or concerns, please contact a member of our support team via live-chat, or by ticket (support@liquidweb.com).