We have confirmed that Cloud Object Storage and Cloud Block Storage are operational, and performance metrics are within normal ranges. Dependent services are also fully functional at this time.
We are continuing to monitor the systems closely to ensure ongoing stability.
If you have any questions or concerns, please feel free to reach out via chat or case.
Thank you for your continued patience.
Posted Jul 11, 2025 - 18:53 EDT
Update
We are continuing to investigate this issue.
Posted Jul 11, 2025 - 18:09 EDT
Investigating
We are currently investigating an issue affecting Cloud Object Storage and Cloud Block Storage. Some customers may experience degraded performance or inability to access services that rely on these storage systems, including Acronis backups.
Our engineering team has identified the root cause, and work is underway to remediate the issue. We will continue to provide updates as more information becomes available.