Degraded Performance with cPanel AutoSSL Issuance
Incident Report for Liquid Web - Services
Resolved
This issue has been resolved.
Posted Oct 04, 2021 - 11:29 CDT
Update
If you are currently having SSL certificate issues and would like to check if it is due to this incident, or due to other causes, the SSLShopper tool is available here: https://www.sslshopper.com. If all checkmarks are green, then this may mean that a system is out of date. In this case start by updating Windows, MacOS, etc. If this does not resolve the issue please reach out to us via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Oct 01, 2021 - 12:07 CDT
Identified
We are currently seeing an issue with degraded performance related to the issuance of cPanel AutoSSL certificates. This is due to a rate limit being imposed on requests by Sectigo, cPanel's AutoSSL certificate provider, as detailed in the following article:

https://support.cpanel.net/hc/en-us/articles/360048668574-AutoSSL-Runs-not-Completing-cPanel-powered-by-Sectigo-cannot-currently-accept-incoming-requests

There is no immediate solution to this as it will be necessary to wait for Sectigo to remove this rate limit, but we will continue to monitor the issue and provide updates as possible.

If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Oct 01, 2021 - 07:25 CDT
This incident affected: CPanel.