Support Request Delays also manage.liquidweb.com and my.liquidweb.com Degraded
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Oct 07, 2022 - 14:22 CDT
Monitoring
Our teams have implemented a fix. Support request resolution times are back to normal, and manage.liquidweb.com and my.liquidweb.com are loading as expected. We're currently monitoring to ensure no recurrences.
Posted Oct 05, 2022 - 17:28 CDT
Investigating
Our teams are currently investigating an issue that is causing delays providing resolutions to support requests.

manage.liquidweb.com and my.liquidweb.com are also currently degraded.

We will update this status post as more information becomes available.

If you have any questions or concerns, please contact a member of our support team via live-chat, ticket (support@liquidweb.com), or by phone at 1-800-580-4985, 1-517-322-0434 (international), communication times are not affected.
Posted Oct 05, 2022 - 14:33 CDT