At this time, the previous maintenance has been completed and services are operating normally moving the matter to a resolution.
Please be advised that another emergency maintenance is scheduled to take place tonight, April 12, 2025, from 10:00 PM to 1:00 AM EDT (April 13, 2025). During this maintenance window, there will be a network service interruption lasting approximately 30 to 60 minutes.
We appreciate your understanding!
Posted Apr 12, 2025 - 17:46 EDT
Monitoring
Earlier today this network maintenance took longer than planned to complete. Our team diligently worked through all issues that were encountered. We understand how important stability is for your services, and we sincerely appreciate your patience as we worked through the issue.
At this time, the maintenance has been completed and services are operating normally. Out of an abundance of caution, we’ll continue to closely monitor the network to ensure stability remains consistent.
Thank you again for your understanding and continued trust.
Posted Apr 11, 2025 - 11:38 EDT
Investigating
Liquid Web Network Engineers are performing scheduled maintenance on network devices in the DC3 Lansing. There may be a brief network disruption that could temporarily affect connectivity.