Business Email Delays or Delivery Failures
Incident Report for Liquid Web - Services
Resolved
The delivery failure rates to Yahoo/AOL postmasters have been addressed by our email vendor. Any delivery failures or deferrals to Google Mail accounts may be due to the sending domain not having the proper Sender Authentication configured in their DNS. Administrators that receive reports of mail not being delivered are encouraged to configure DKIM on their domain and update their DNS with the recommended SPF record.

Gmail is requiring the Sender's mailbox to have their SPF and DKIM record configured properly so that the Gmail servers can perform their required security checks. Please ensure these records are added to your domain:
https://help.liquidweb.com/s/article/Managing-DNS-for-Premium-Business-Email - see SPF section
https://help.liquidweb.com/s/article/Enabling-DKIM-for-Premium-Business-Email

Please contact our support team if you need assistance with that.
Posted Jun 20, 2022 - 08:49 CDT
Monitoring
The increase in mail being deferred by Google and Gmail is due to the sending domain not having the proper Sender Authentication configured in their DNS. Administrators that receive reports of mail not being delivered are encouraged to configure DKIM on their domain and update their DNS with the recommended SPF record.

Please contact support if you need any assistance with that.
Posted Jun 15, 2022 - 07:48 CDT
Update
Our email vendor has confirmed that Email users are experiencing bounce-backs from Google Mail due to GMAIL's Security Check Policies. To resolve these bounces, Gmail requires the following action for each scenario:

Auto Forwarding from Business Email to Google Mail
In this case GMAIL is requiring that your Business Email address is added as an alias to your Gmail account. This is Gmail's way of doing a thorough check to ensure the auto-forward is legitimately intended by both mailboxes.

https://support.google.com/mail/answer/22370
*Note: Please allow propagation time after configuring this setting.

Manual Forwarding to Gmail
In this case Gmail is requiring the Sender's mailbox to have their SPF and DKIM record configured properly so that the Gmail servers can perform their required security checks. Please ensure these records are added to your domain:
https://help.liquidweb.com/s/article/Managing-DNS-for-Premium-Business-Email - see SPF section
https://help.liquidweb.com/s/article/Enabling-DKIM-for-Premium-Business-Email
Posted Jun 10, 2022 - 14:56 CDT
Update
Our email vendor has let us know they are still working directly with the Yahoo/AOL postmasters to resolve the issue. It is limited to a just a subset of our vendor's sending IPs, and Yahoo is being very responsive as they work through the issue together.

We will provide updates as we have them.
Posted Jun 10, 2022 - 10:33 CDT
Identified
Our email vendor has noticed bounce backs above the normal threshold from various third party email providers . While measures are being taken to prevent any impact to users, some may experience mail delivery delays or delivery failures. Impacted users are encouraged to retry their messages.

Our email vendor's Leadership, Anti-abuse, and Postmaster teams have been partnering with the affected recipient mail hosts and their internal reporting has shown significant improvements in deliverability, however, they are continuing to work towards full remediation of this issue.
Posted Jun 07, 2022 - 11:57 CDT
This incident affected: Business Email.