Acronis Portal Performance Degraded
Incident Report for Liquid Web - Services
Resolved
This issue has been resolved and the Acronis Backup Portal is operating normally at this time.
Posted May 22, 2021 - 19:10 CDT
Investigating
We've been alerted to an issue that's impacting performance while attempting to access the Acronis Backup Portal. We're currently investigating to resolve this issue as quickly as possible. We apologize for any inconvenience that this may cause.
Posted May 22, 2021 - 18:42 CDT