Business Email Control Panel/Webmail Change Delays
Incident Report for Liquid Web - Services
Resolved
The issues with the control panel actions and web mail are now resolved.
Posted May 26, 2022 - 09:07 CDT
Investigating
We are aware of an issue within our email vendor's Control Panel and Webmail interface that is resulting in delays when accessing or making changes. This includes but is not limited to the following:

Password Changes
Modifying Mailboxes and Administrators
Mailbox Creation
Mailbox Forwarding
Settings Automatic Replies

Their Engineers are engaged and investigating this issue. In the meantime, we recommend that administrators avoid making any changes until further notice. We will provide updates as we have them.
Posted May 26, 2022 - 07:13 CDT
This incident affected: Business Email.