Acronis Single Sign-on Failure
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Apr 20, 2020 - 10:30 CDT
Investigating
We have detected an issue which is currently preventing logins to the Acronis Cyber Backup management portal. We are currently investigating to work toward a resolution of this issue.
Posted Apr 17, 2020 - 15:15 CDT
This incident affected: Management Portal.