Premium Business Email Webmail Issues
Incident Report for Liquid Web - Services
Resolved
This issue has been resolved.
Posted Jun 04, 2024 - 14:11 EDT
Investigating
Our email vendor has identified an issue with the Premium business webmail access. Engineers are actively engaged in resolving the issue.

This may be affecting the ability to manage the emails.

We appreciate your patience in the matter, and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Jun 04, 2024 - 11:48 EDT
This incident affected: Business Email.