Rack Switch Down - Lansing DC3

Incident Report for Liquid Web - Services

Resolved

The connectivity issue affecting a rack switch in our Lansing Data Center has been fully resolved, and everything is operational.
Posted May 07, 2025 - 16:36 EDT

Monitoring

The connectivity issue affecting a rack switch in our Lansing Data Center has been fully resolved. Our team is closely monitoring the network to ensure ongoing stability and optimal performance.
Posted May 07, 2025 - 15:13 EDT

Investigating

We recently identified an issue with a rack switch in one of our Lansing Data Centers. If your server is located in the affected area, you may have experienced a brief disruption in connectivity or a temporary increase in latency.

The Network Team is actively working on a resolution; we are aware of the impact and will keep you updated on progress.

Our teams are here to help you. Please do not hesitate to get help via Chat or Case at my.liquidweb.com.
Posted May 07, 2025 - 15:07 EDT
This incident affected: Data Centers (DC3 - LAN).