Issues opening new Tickets within help.liquidweb.com
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Apr 20, 2022 - 19:09 CDT
Investigating
We are investigating an issue that is preventing customers from opening new tickets within help.liquidweb.com.
New tickets are still generated via emailing support@liquidweb.com

If you have any questions or concerns, please contact a member of our support team via live-chat, ticket (support@liquidweb.com), or by phone at 1-800-580-4985, 1-517-322-0434 (international).
Posted Apr 20, 2022 - 18:37 CDT
This incident affected: Support Services (Ticket Support).