Partial Amsterdam outage

Incident Report for Liquid Web - Services

Resolved

This incident has been resolved.
Posted Oct 23, 2025 - 18:50 EDT

Identified

A PDU was turned off due to a tripped fuse. We are working on restoring power to the servers.
Posted Oct 23, 2025 - 17:56 EDT

Investigating

A subset of our Amsterdam servers is unreachable - we are investigating the issue and will provide updates when we can.

If you have any questions or concerns, please contact a member of our support team via live-chat or ticket (support@liquidweb.com).
Posted Oct 23, 2025 - 17:05 EDT
This incident affected: Data Centers (EU - AMS).