Customer ticket creation and response degraded service
Incident Report for Liquid Web - Services
Resolved
The updates have been completed and this incident is resolved
Posted Oct 19, 2022 - 16:13 CDT
Monitoring
Our team has implemented a fix and are monitoring issue moving forward
Posted Oct 19, 2022 - 15:05 CDT
Investigating
We are currently investigating an issue where customer ability to create ticket is currently offline. Our Salesforce engineers are working on a fix and will update status as we have further information.

You can still call or chat in should you need immediate support - by phone at 1-800-580-4985, 1-517-322-0434 (international)
Posted Oct 19, 2022 - 15:02 CDT
This incident affected: Support Services (Ticket Support) and Management Portal.