Liquid Web Outage
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Dec 12, 2024 - 13:10 EST
Monitoring
A fix has been implemented and services are functioning as expected at this time. We are currently monitoring to ensure stability.
Posted Dec 11, 2024 - 11:37 EST
Identified
We have identified an issue causing our websites and hosting services to experience interruptions. We will update this status post as more information is available.

We sincerely appreciate your understanding and patience as we resolve this issue. Thank you for your continued support.

Our teams are here to help you. Please do not hesitate to get help via live-chat, ticket or by toll-free phone at 1-800-580-4985 or internationally at 1-517-322-0434.
Posted Dec 11, 2024 - 11:32 EST