Business Email Webmail Issues
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Sep 01, 2020 - 13:34 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 01, 2020 - 11:20 CDT
Investigating
We are working with our vendor to identify and resolve the cause of the webmail issues for the Business Email service.

We will keep you posted here as we gather additional details. We appreciate your patience and if you have any questions feel free to reach out to a member of our support team via ticket or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Sep 01, 2020 - 09:37 CDT
This incident affected: Business Email.