Premium Business Email Delivery Delays
Incident Report for Liquid Web - Services
Resolved
This issue has been resolved.
Posted Apr 16, 2024 - 11:03 EDT
Update
Email Engineers are still working on getting IPs delisted from the corresponding providers. Email delivery will be getting increasingly better as our team finishes that up.

Thank you for your patience while we work with them to resolve this issue. If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Apr 16, 2024 - 08:24 EDT
Monitoring
Email Engineers found and corrected an issue in the system. They are still working on getting IPs delisted. Email delivery will be getting increasingly better as our team finishes that up.

Thank you for your patience while we work with them to resolve this issue. If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Apr 12, 2024 - 12:11 EDT
Update
Our Email Vendor is still investigating an issue that may be delaying incoming traffic to the Premium Business Email environment. Messages that are delayed will still be delivered and their engineers are engaged.

Yahoo/AOL Bouncebacks
Email Engineers are actively partnering with affected recipient mail hosts, significantly improving deliverability. While they work to resolve this issue fully, some users may still experience mail delivery delays or failures. If you encounter problems, please retry sending your messages and advise recipients to safelist your domain for smoother delivery.

Thank you for your patience while we work with them to resolve this issue. If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Apr 11, 2024 - 23:28 EDT
Identified
Our Email Vendor is aware of an issue that may be delaying incoming traffic to the Premium Business Email environment. Messages that are delayed will still be delivered and their engineers have been engaged.

Yahoo/AOL Bouncebacks
Email Engineers are actively partnering with affected recipient mail hosts, significantly improving deliverability. While they work to resolve this issue fully, some users may still experience mail delivery delays or failures. If you encounter problems, please retry sending your messages and advise recipients to safelist your domain for smoother delivery.

Thank you for your patience while we work with them to resolve this issue. If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Apr 10, 2024 - 09:05 EDT
This incident affected: Business Email.