Servers are fully operational. Our Engineers are still mitigating and monitoring the situation. We appreciate your patience and understanding while we work to resolve this issue.
If you have any questions or need assistance, please chat with us or create a case via my.liquidweb.com.
Posted Mar 25, 2026 - 08:38 EDT
Update
We are continuing to investigate network performance issues affecting servers in our Phoenix Data Center. Some clients may still experience connectivity issues. Our Engineers are actively working to isolate the cause and restore full stability as quickly as possible. Need help? Chat with us or create a case via my.liquidweb.com . We appreciate your patience and understanding as we work to resolve this issue. Thank you.
Posted Mar 25, 2026 - 06:53 EDT
Investigating
We are investigating network performance issues affecting servers in our Phoenix Data Center. You may experience connectivity issues. Our Engineers currently investigating the issue to isolate the cause and restore stability.
Need help? Chat with us or create a case via my.liquidweb.com.
We appreciate your patience and understanding as we work to restore this service. Thank you.