Email issues: Service degradation on Microsoft 365 (Business or Enterprise).

Incident Report for Liquid Web - Services

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 04:32 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 23, 2026 - 01:56 EST

Identified

Microsoft is currently experiencing widespread service degradation. This issue specifically impacts users attempting to send or receive emails to Microsoft-hosted accounts (including Outlook, Hotmail, and Office 365).

Affected users may experience limited functionality across multiple Microsoft 365 services or receive delivery errors such as "451 4.3.2 Temporary server" or "Host lookup failed."

Our team is monitoring the situation closely and will provide further updates as more information becomes available. We appreciate your patience and understanding.

If you need any help, please chat with us or create a ticket via my.liquidweb.com.
Posted Jan 23, 2026 - 00:50 EST