Internal Network Outage Impacting Support Services.

Incident Report for Liquid Web - Services

Resolved

This issue has been fully resolved, and all services are operating normally.

We have continued to monitor the environment and have not observed any further issues. Customer websites and services remain fully operational, and support response times have returned to normal.

If you experience any issues or need assistance, please reach out via Live Chat or by submitting a support case.

We appreciate your patience throughout this incident.
Posted Apr 10, 2026 - 14:14 EDT

Monitoring

Our internal network issue has been mitigated, and services have returned to normal operation. Our Network Engineering team will continue to monitor the environment to ensure stability.

Customer websites and services remain fully operational. Support response times are returning to normal.

If you continue to experience any issues or need assistance, please reach out to us via Live Chat or by submitting a support case.

We appreciate your patience and will provide further updates if necessary.
Posted Apr 10, 2026 - 13:36 EDT

Investigating

We are currently experiencing an issue with our internal network. Our Network Engineering team is actively working to resolve this as quickly as possible.

This issue does not impact customer websites or services, which remain fully operational. However, there may be delays in support response times during this period.

If you have any questions or need assistance, please reach out to us via Live Chat or by submitting a support case.

We appreciate your patience and will provide updates as progress is made.
Posted Apr 10, 2026 - 11:16 EDT
This incident affected: Support Services (Chat, Case, Phone).