Help Center performance degraded
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Feb 18, 2020 - 16:31 EST
Identified
At this time we've noticed some degraded performance in the help center and are currently investigating. More information will be provided as it becomes available.
Posted Feb 17, 2020 - 10:55 EST
This incident affected: Support Services (Chat Support).