Issues with Windows Server 2019 Windows Update

Incident Report for Liquid Web - Services

Monitoring

The issue has been identified, and we will continue to monitor affected systems for any further impact.

Our Windows Engineering team has confirmed the incident is related to the November 11th, 2025 cumulative update (KB5068791 – OS Build 17763.8027).
You can review Microsoft’s official release notes here:
https://support.microsoft.com/en-us/topic/november-11-2025-kb5068791-os-build-17763-8027-485c3175-0dc0-45c6-8328-553863ea2cbc#id0ebdh=windows_server_2019

We will continue to monitor affected systems closely and provide updates as additional information becomes available.

Our support team is on standby if you need any help or have questions or concerns. You can connect with us through the following channels:

Live Chat: https://my.liquidweb.com/
Email: support@liquidweb.com
Posted Nov 12, 2025 - 12:18 EST

Update

Our Windows Engineering team is currently investigating a November 11th release KB5068791 (OS Build 17763.8027). Windows support article. https://support.microsoft.com/en-us/topic/november-11-2025-kb5068791-os-build-17763-8027-485c3175-0dc0-45c6-8328-553863ea2cbc#id0ebdh=windows_server_2019.

We will provide updates as we have more details to share.
Posted Nov 12, 2025 - 10:50 EST

Investigating

We are currently investigating an issue that is impacting Windows Servers 2019 with a recent Windows update . We will provide updates as we learn more.

If you have any questions or concerns, please contact a member of our support team via live-chat or case (support@liquidweb.com).
Posted Nov 12, 2025 - 10:50 EST