Issues with Toll-free number
Incident Report for Liquid Web - Services
Resolved
Our upstream telephonic provider was experiencing technical issues that disrupted their ability to provide us service. These have since been identified and corrected by them. At this time our 800 numbers are working optimally once more.
Posted Oct 06, 2021 - 22:31 CDT
Investigating
We have identified an issue with our toll-free number and we're actively engaged on the issue.

In the meantime, please use 517-322-0434 or contact a member of our support team via live-chat or ticket (support@liquidweb.com).
Posted Oct 06, 2021 - 20:22 CDT
This incident affected: Support Services (Phone Support).