DNS Service Disruption
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Apr 20, 2022 - 19:34 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 20, 2022 - 18:55 EDT
Investigating
We're currently investigating an issue with DNS/networking that is causing customer sites to not load. We apologize for the inconvenience - we are working as fast as possible to get this resolved.

If you have any questions or concerns, please contact a member of our support team via live-chat, ticket (support@liquidweb.com), or by phone at 1-800-580-4985, 1-517-322-0434 (international).
Posted Apr 20, 2022 - 18:20 EDT
This incident affected: DNS.