Blacklisted IPs
Incident Report for Liquid Web - Services
Resolved
IPs have been delisted and additional monitoring has been put in place to help avoid this in the future.
Thank you for your patience.
Posted Mar 05, 2021 - 10:18 EST
Investigating
Teams are currently investigating a report of IP addresses showing on a less commonly used blacklist, and are working to resolve the issue. Some customers have experienced a delay in email delivery as a result. If you experience any issues, please feel free to reach out to our Support Team at 1.855.348.9060 or international at +1.517.322.0434.
Posted Mar 01, 2021 - 10:21 EST